Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 21, 2026 - 18:20 CDT
Scheduled
We are currently addressing an issue affecting one of our backup infrastructure hosts. Maintenance will be performed to replace a failed hardware component and restore normal operations.
During this maintenance window, backup jobs associated with the affected system will be temporarily paused. Existing backup data remains intact, and services will resume once the host has been recovered and validated.
We will provide further updates as work progresses and when backup operations have been fully restored.
Impact: Backup processing is temporarily paused for affected systems. This maintenance is limited to our backup infrastructure and is not expected to impact our Virtual Machine infrastructure. Our engineering team is actively monitoring the environment throughout the maintenance window.
Posted Jul 21, 2026 - 18:19 CDT
This scheduled maintenance affected: Network Infrastructure (Zone E - US East).