Cloudflare Global Network experiencing issues

Incident Report for xByte Cloud

Resolved

Cloudflare’s global network issues appear to have been resolved across our network as well as other networks throughout the U.S. Our team sent out a notice as an additional communication measure for customers who rely on Cloudflare in their environments.
As an added layer of redundancy, we recommend having a backup or failover plan in place to protect against future global outages. If you’d like recommendations for alternative providers, please reach out to our team at help@xbytecloud.com, and we’ll be happy to provide options.
Posted Nov 18, 2025 - 09:45 CST

Update

Cloudflare has reported the issue as being resolved and a fix in place. All our systems show resolved at this time. We will continue to monitor the issue.
Posted Nov 18, 2025 - 08:48 CST

Update

Cloudflare has reported that they've identified the issue and are working on implementing a fix.
Posted Nov 18, 2025 - 07:36 CST

Monitoring

Cloudflare continues to investigate the issue. We've encountered services recovering and then being impacted again as the remediation efforts continue.
Posted Nov 18, 2025 - 06:29 CST

Identified

Cloudflare has reported a global network issue. We are monitoring the issue and will provide updates as they become available. The issue can also be tracked at the following link: https://www.cloudflarestatus.com/
Posted Nov 18, 2025 - 05:35 CST