Cloudflare Empty Form/POST Submissions

Incident Report for xByte Cloud

Resolved

This incident has been resolved.
Posted Jul 17, 2026 - 12:08 CDT

Monitoring

Cloudflare has implemented a fix for the issue: https://www.cloudflarestatus.com/
We will monitor for another hour to confirm before marking as resolved.
Posted Jul 17, 2026 - 11:34 CDT

Identified

Cloudflare has officially posted the issue being reported: https://www.cloudflarestatus.com/
We will continue monitoring.
Posted Jul 17, 2026 - 10:08 CDT

Investigating

We have begun receiving reports of Cloudflare-enabled domains intermittently receiving empty form/POST submissions.

Based on the reports we've seen so far, this appears to be related to a broader upstream issue impacting Cloudflare rather than an issue specific to our platform. We are monitoring the situation and will share updates as more information becomes available.
Posted Jul 17, 2026 - 09:00 CDT